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Getting Started 
 
About File Transfer Protocol 
 
One of the oldest Internet protocols still in use today is the File Transfer Protocol, known as FTP, which was first developed in 1971.  
FTP, a standard Internet protocol, is the simplest way to exchange files between computers on the Internet. Like Hypertext Transfer 
Protocol (HTTP), which transfers Web pages and related files, and Simple Mail Transfer Protocol (SMTP), which transfers e-mail, FTP 
is an application protocol that uses the Internet's TCP/IP protocols.  FTP is commonly used to transfer Web page files from their creator 
to the computer that acts as their server for everyone on the Internet. It's also commonly used to download programs and other files to 
your computer from other servers. 
 
About CuteFTP 
 
CuteFTP is a Windows-based File Transfer Protocol (FTP) application that allows you to utilize the capabilities of FTP without having to 
know all the details of the protocol itself.  CuteFTP simplifies FTP by offering a user-friendly Windows interface instead of a 
cumbersome command-line utility.  CuteFTP gives novice PC users the ability to upload, download, and edit files on remote FTP 
servers around the world.   
 
System Requirements 
 

• Any PC running Windows 95/98/2000/ME/XP/XP Pro or NT 4.0. 
• At least 16 MB of free memory, 3-5 MB of free hard disk space and a CD-ROM drive. 
• A connection to the Internet. 

 
Installing CuteFTP 
 

1. Click the Start button and select Run.  Note: If you are installing from a CD, the installation process will begin automatically. 
 

2. Click the Browse button to locate cuteftp.exe. 
 

3. Click the OK button 
 

4. Follow the on-screen instructions. 
 
Uninstalling CuteFTP 
 
The uninstall function removes CuteFTP from your PC.  It also removes the CuteFTP icon from your Desktop.  However, your Site 
Manager data will remain.  To uninstall CuteFTP: 
 

1. Click Start > Settings > Control Panel. 
 

2. Then select Add/Remove Programs. 
 

3. Choose CuteFTP from the list and click the Add/Remove button. 
 

4. Follow the on-screen instructions. 
 
Registering CuteFTP 
 
When you purchase CuteFTP you will receive a serial number that you must enter into your trial copy of CuteFTP in order for it to work 
beyond the 30-day trial.  Perform the following steps to register CuteFTP: 
 

1. Start CuteFTP. 
 

2. Click the Enter Serial Number button on the Evaluation Period screen. 
 

3. Enter your serial number into the Serial Number box. 
 

4. Enter you name into the Registered User Name box. 
 

5. Click the Register button. 
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CuteFTP's Main Screen  
The main screen is used to transfer files to and from remote servers and is divided into four windows: an upper window, two center 
windows, and a lower window.  The two center windows represent files available on local and remote drives, much like Windows 
Explorer. 
 

• Upper window (Log Window): The Log Window displays the commands you send and the server's responses.  CuteFTP 
logs this information to inform you of completed transactions or assist in troubleshooting. 

 
• Center left window (Local Window): The Local Window displays files and folders from your hard drive. 

 
• Center right window (Remote Window): The Remote Window displays the files and folders on the remote server. 

 
• Lower window (Queue Window): The Queue Window shows the files currently being transferred to the server.  If you want to 

transfer files at a later time, you can also store them here temporarily. 
 
  
Changing the default start-up window  
 
CuteFTP allows you to decide which window to display when the program opens: Site Manager, Default Wizard Site, Quick Connect 
or Nothing.  Perform the following steps to change the default start-up window: 
 

1. From the menu bar choose Edit > Settings > Connection. 
 

2. Choose the desired start-up window from the Upon startup launch drop down box. 
 

3. Click the OK button. 
 
Connecting to an FTP server using the Site Manager 
 
The Site Manager is a database that stores information about FTP servers such as address, username and password.  The most 
common way to connect to an FTP server is by accessing it through the Site Manager by performing the following steps: 
 

1. From the menu bar choose File > Site Manager. 
 

2. Select a site from the list in the Site Manager window. 
 

3. Click the Connect button to connect to the FTP server. 
 
Connecting to an FTP server using Quick Connect 
 
CuteFTP includes an address bar much like a browser.  You can type the address, username and password for the FTP site into the 
Quick Connect bar by performing the following steps: 
 

1. Select File > Quick Connect from the menu bar. 
 

2. Enter the FTP site address in the Host field, and a Username and Password if necessary. 
 

3. Press the Enter button on your keyboard to connect. 
 
Note 
To add the FTP server to your Site Manager choose Commands > Session > Add Session to Site Manager before breaking the 
connection. 
 
Disconnecting from an FTP server 
 
To disconnect from an FTP server, select File > Disconnect from the menu bar or click the Disconnect button on the toolbar. 
 
Reconnecting to an FTP server 
 
To reconnect to an FTP server, select File > Reconnect from the menu bar or click the Reconnect button on the toolbar. 
 
Opening multiple sessions of CuteFTP 
 
CuteFTP will allow you to open multiple sessions.  This is useful when you are downloading a file from one site and want to browse or 
download a file from another site simultaneously. To launch another session of CuteFTP with the same site open, select Commands > 
Session > Spawn Current Session from the menu bar.  
 



CuteFTP 5 XP User’s Guide 5

Working With the Site Manager 
 
Adding a site using the Connection Wizard 
The Connection Wizard breaks the site setup process into easy-to-understand screens.  Perform the following steps to use the 
Connection Wizard: 
 

1. Select File > Connection Wizard from the menu bar. 
 

2. Enter a Site Label.  Type in a word or words that describe your site.  This label is shown on your Site Manager screen. 
 

3. Enter the Host Address (hostname or IP address).  Type in the address of your FTP server, i.e. ftp.cuteftp.com.  If you do 
not know the address, contact the administrator of the site or your Internet Service Provider. 

 
4. Enter your user ID and password.  Your user IDs and passwords are provided by your Internet Service Provider.  Both are 

case sensitive. The following options are also available: 
 

• Anonymous Login:  This option will use your email address as the password.  If you log in anonymously you will not 
have the same permissions as you would if you logged in using your password. 

 
• Mask Password:  If selected, asterisks will appear as each letter of the password is typed.  Once Mask Password is 

selected and you begin typing your password, you cannot deselect Mask Password to see letters instead of asterisks. 
 

5. Specify a Default Local Directory.  This optional field is part of the Connection Wizard.  Leave this field blank if you do not 
want to specify a default directory.  Enter information in this field if you want to move to a specific local directory when you 
connect to the site being added. 

 
6. Click in the box next to one or both of the following options: 

 
• Connect to this site automatically:  If you want to go to your new site when starting CuteFTP, select this item. 

 
• Add to right click shell integration:  This choice enables you to upload files or folders to a site by right-clicking 

items on the Windows Desktop or Explorer.  
 
Adding a site to the Site Manager 
 

1. From the menu bar, select File > Site Manager.  
 

2. Select an existing folder from the directory tree on the left or create a new folder for the site. To create a folder, select File > 
New Folder from within the Site Manager.  

 
3. Click the New button. Enter a name for your site in the Label for site field. 

 
4. Enter the FTP server address in the FTP Host Address field. This is the address of your FTP server, i.e. ftp.cuteftp.com.  If 

you do not know the address, contact the administrator of the site or your Internet Service Provider.  Do not type in ftp:\\ or 
http:\\ before the server address. 

 
5. Enter your user ID in the FTP Site User Name field.  Your user ID is provided by your Service Provider and is case sensitive. 

 
6. Enter your password in the FTP Site Password field.  The password is provided by your Service Provider and is case 

sensitive.  
 

7. If the site requires a port other than 21 to establish a connection (almost all FTP sites use 21), enter it in the FTP site 
connection port field. 

 
8. Select the Login Type. Three types are available: 

 
• Normal: used if a username and password are required. 

 
• Anonymous: used to connect to anonymous FTP sites. 

 
• Double: used when a dual login is required. Note:  An anonymous login will automatically be supplied to the server 

and then a second login will occur using the supplied user name and password. 
 

9. To connect to your new site, highlight the site name in the left window and push the Connect button. 
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Modifying an existing site in the Site Manager 
 
Existing sites may be modified at any time by performing the following steps:  
 

1. From the menu bar, select File > Site Manager. 
 

2. Select the site you want to modify in the left window. 
 

3. You can then modify its basic settings in the right-hand side of the window.  More settings are available by clicking the Edit 
button.  See Site Manager Settings for a complete description of the available settings. 

 
Removing a site from the Site Manager 
 
! To remove a site from the Site Manager, select the site from the list and then select Edit > Delete from the Site 

Manager menu bar.  
 
Password protecting your Site Manager 
 
CuteFTP allows you to password protect your Site Manager using BlowFish Encryption.  When you password protect the Site Manager, 
you will be required to provide the password the first time you launch the Site Manager during a new session of CuteFTP.  Perform the 
following steps to password protect your Site Manager: 
 

1. Start the Site Manager by choosing File > Site Manager on the menu bar.  
 

2. Choosing Security > Set Password from the Site Manager menu bar.  
 

3. Enter and confirm your password. 
 

4. Click the OK button. 
 
Note 
You can also clear or change your password by choosing Security > Clear Password or Security > Change Password respectively. 
 
Importing sites from previous versions of CuteFTP 
 
CuteFTP's Site Manager now houses its data in a file called sm.dat, located in the CuteFTP directory. Older versions of CuteFTP use 
tree.dat (before 2.5) or smdata.dat (2.5 to 3.5). Importing the Site Manager files will allow you to access your old sites.  Perform the 
following steps to import your previous Site Manager data: 
 

1. Choose File > Site Manager from the menu bar. 
 

2. Click the Import button in the Site Manager 
 

3. Browse for your existing Site Manager file 
 

4. Click the Open button.  The sites now appear in your Site Manager.  If the tree.dat file that you imported was also in the same 
directory where the bookmark.dat was, then even your old bookmarks will be imported. 

 
Site Manager Settings 
 
To access the following Site Manager settings: 
 

1. Choose File > Site Manager from the menu bar. 
 

2. Select the site you want to modify. 
 

3. Click the Edit button. 
 

4. Select the General tab. 
 
Under the General tab: 
 

• Host Type: By default CuteFTP will automatically detect which type of server (host) it is connecting to.  Use the drop-down 
menu to select a server type if problems occur connecting to a specific host.   

 
• Default Remote Directory/ Default Local Directory:  Specify the initial remote/local folders you want CuteFTP to go to when 

you connect to the site.  

ftp://ftp.cuteftp.com/
ftp://ftp.cuteftp.com/
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• Site Comments:  Use this field to type comments about the FTP site. This has no effect on the connection to the site.   
 

• Enable Filter:  This setting activates filtering. Click Filter to edit defined filters.  See the Filtering Files & Folders section for 
more information. 

 
• PASV Mode:  CuteFTP uses PASV mode to initiate all connections while the server only waits for requests.  When active, this 

feature helps avoid conflicts with the security system.  PASV mode is active by default. 
 

• Enable Firewall Access: This field is active by default.  CuteFTP uses the settings defined in the Firewall section of the Edit 
> Settings window.  

 
Under the Advanced tab: 
 

• Connection Options:  The Connection Retries field specifies how many times CuteFTP should attempt to connect to the 
server.  The Delay between retries field tells CuteFTP how long in seconds to wait after an unsuccessful attempt before 
trying to reconnect.  You can modify these on a per site basis by un-checking the Use default settings check box.  If that box 
is checked you will inherit the global settings found at Edit > Settings > Connection from the menu bar. 

 
• Use AutoRename Scheme:  Active by default, this feature renames file extensions before uploading to the server.  Renaming 

file extensions is helpful if the extension on the local side is different from the extension required by the server or remote side.  
See the Automatically Renaming Transferred Files section for more information. 

 
• File Name Case Handling:  CuteFTP can "force" a file to upload in lower, upper, or preserved case.  This is helpful if you 

created files with mixed case on your system, but need the files to be in upper or lower case on your server. 
 

• Max Safe Index Size: Many FTP servers contain files that contain information about other files on the server.  These are 
known as Index files.  CuteFTP uses Index files to fill in the Description field on the remote window.  You can control how 
large an Index file CuteFTP is allowed to download without prompting by entering the Max Safe Index Size.  You can modify 
these on a per site basis by un-checking the Use default settings check box.  If that box is checked you will be inherit the 
global settings found at Edit > Settings > Connection > Index Files from the menu bar.  

 
• Auto-Cache Index Files:  Checking this box will cause CuteFTP to search for Index files and automatically load them in 

memory. 
 

• Transfer Type:  Select ASCII or Binary to force those transfer modes, or select AutoDetect to have CuteFTP determine 
transfer types for you. 

 
• Simple Directory Listing:  CuteFTP will display file names only in directory listing. 

 
• Enable Smart Keep Alive:  Check to have Smart Keep Alive maintain a connection automatically.  See the Smart Keep Alive 

section for more information. 
 

• Use Logical Parent Directory:  Checking this box causes CuteFTP to specify the previously visited directory as the parent 
directory rather than the actual physical parent. 

 
• Save Session Log to file: Save log files for this FTP site.  The location of the log file can be changed at Edit > Settings > 

Connection > Log. 
 

• Add Site to shell integration:  Site Manager entries that have this check box checked will be added to your right-click menu. 
 

• Cache site "resume" status:  If checked, CuteFTP will remember that the site either does or does not support resuming 
transfers, which can speed up connection times. 

 
• Use as default login site:  When checked, this site becomes the default site that CuteFTP automatically connects to, if you 

have the Edit > Settings > Connection > Upon Startup Launch feature set to Connect to Default Site. 
 

• Check file size on download:  After a file is downloaded, CuteFTP will compare the server's original file size to the size of the 
downloaded file to ensure that the transfer is complete and accurate.  Transfer Type allows users to specify one of four 
choices: 

 
o Use Global Settings:  This choice is on by default. This means that users can adjust their Global Settings in order to 

alter this choice for every site with Use Global Settings specified. 
o On:  With this choice selected, CuteFTP will check download size for every file after downloading. 
o Off:  CuteFTP will not check file size. 
o Auto:  CuteFTP will check file size if the server permits this action. 
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Transferring Files with CuteFTP 
 
Transferring files 
 
Once you are connected to a remote server, there are many ways to start file transfers: 
 

• Drag-and-Drop:  Select the file you want to transfer.  Using your left mouse button, "grab" the highlighted file, drag the file to 
the opposite window, and drop the file anywhere in that window (including folders). 

 
• Menu/Toolbar:  Select the files you want to transfer.  Select Transfer > Upload or Transfer > Download from the menu bar, 

or click the Upload or Download buttons on the toolbar. 
 

• Double-click the file:  Highlight the file to transfer and double-click. 
 

• Queue:  Highlight the file you want to transfer and drag it to the Queue window and choose Transfer > Transfer queue from 
the menu bar. 

 
• Right-click Context Menu: Select the file in CuteFTP’s main window, right-click and then select Upload or Download. 

 
• Right-click shell integration: From Windows Explorer, right-click the file or folder you want to transfer and choose CuteFTP 

Upload.  The FTP sites you have specified in the Site Manager for use in Windows Explorer or Desktop will be listed.  Choose 
the desired site and CuteFTP will begin uploading.  To enable Shell Integration, go to the section of the Edit > Settings > 
Advanced from the menu bar.  Click Enable Right-Click Shell Integration to activate the feature. 

 
• Cut or Copy & Paste:  Select a file in CuteFTP’s main window and choose Edit > Cut to move the file or Edit > Copy to copy 

the file.  Then, select the opposite pane and choose Edit > Paste to transfer the file. 
 
Stopping transfers 
 
CuteFTP uses persistent transfers to resume and complete transfer requests stopped by a broken connection.  You must disable the 
persistent transfer feature to permanently stop a transfer.  To disable persistent transfers, deselect Enable Persistent Downloading in 
the Connection section of the Edit > Settings window. To stop a transfer either select Transfer > Stop from the menu bar, press the 
Stop button on the toolbar, or press F9. 
 
Resuming transfers 
 
If it is disconnected while downloading or uploading a file, CuteFTP will automatically reconnect and attempt to send the file until the 
transfer is successful.  To disable this function, see Stopping Transfers. 
 
To manually resume a transfer start the transfer process again.  CuteFTP will see that you are replacing an existing file and it will ask 
whether you want to “Resume", "Overwrite", or "Skip" the transfer.  Choose Overwrite if you are replacing the file.  Choose Resume 
to complete a broken transfer, or Skip to cancel the operation.  
 
Note 
The resume command must be supported by the FTP server in order for this to work.  If the FTP server does not support resume, the 
Resume button will be grayed out. 
 
Scheduling file transfers 
 
CuteFTP has the capability to automate file transfers using the built-in scheduler. Perform the following steps to schedule a file transfer: 
 

1. Connect to the site you want to transfer files to or from. 
 

2. Navigate to the local and remote folders you want to transfer files to or from. 
 

3. Select the files to transfer and add them to the queue. 
 

4. Select Transfer > Queue > Save Queue from the menu bar. 
 

5. Select Transfer > Schedule Transfers from the menu bar and check Enable Scheduler. (Check Show countdown timer if 
you want to display a countdown until transfer time).  Be sure the Enable scheduler check box is checked. 

 
6. Click Add Queue File and select the queue file (*.que) saved in step 4.  You can also click the Add wildcard button to select 

all .que files in a folder. 
 

7. Select a date and time to initiate the queue transfer.  You can also choose to repeat the transfer by day, week, or month. 
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8. Click the OK button. 

 
 
Rescheduling file transfers 
You can reschedule an existing scheduled transfer by performing the following steps: 
 

1. Choose Transfer> Schedule Transfers from the menu bar. 
 

2. Select the queue file to change. 
 

3. Click the Edit button to reschedule. 
 

4. Click the OK button 
 
 
Scheduling currently queued files 
If you have already queued several files you may add them to the scheduler by performing the following steps: 
 

1. Choose Transfer > Schedule Transfers from the menu bar. 
 

2. Check the Schedule current queue check box. 
 

3. Enter the date and time to initiate the transfer.  Note: The current queue must be scheduled to run before any other scheduled 
queues. 

 
4. Click the OK button. 

 
 
Disabling the scheduler: 
Perform the following steps to postpone any scheduled file transfers: 
 

1. Choose Transfer> Schedule Transfers from the menu bar. 
 

2. Uncheck Enable Scheduler in the scheduler dialog box. 
 

3. Click the OK button. 
 
 
Site-to-Site Transfers 
 
CuteFTP is capable of transferring files from one remote server to another. Some servers do not allow this style of transfer; if you are 
having difficulty getting this feature to function properly, please contact the administrator of the FTP site to see if Site-to-Site Transfers 
are supported.  Perform the following steps to transfer a file from one remote server to another 
 

1. Start CuteFTP and connect to the first remote site. 
 

2. Choose Window > New CuteFTP Window from the menu bar to launch another session of CuteFTP. 
 

3. Connect to the second site in the new session. 
 

4. Drag and drop the desired file from one window to the other. 
 
 
Setting the transfer type (ASCII/Binary) 
 
CuteFTP is programmed to automatically select the proper transfer type (Auto).  To manually specify a file transfer type, select Edit > 
Settings from the menu bar and go to the ASCII/Binary section.  Choose the radio button for the transfer type you prefer. 
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Files and Folders 
 
Viewing a file on an FTP site 
 
You can use Notepad to view files on an FTP site by doing the following: 
 

1. Connect to the FTP site and navigate to the folder containing the text file. 
 

2. Select the file you want to view 
 

3. Choose Commands > File Actions > View from the menu bar. 
 
Note 
Notepad is the default viewer.  You can change the default viewer under Edit > Settings > Helper Applications from the menu bar. 
 
Editing a file on an FTP site 
 
CuteFTP allows you to modify a text file on a remote FTP server without downloading, opening, saving and uploading the file.  Do the 
following to modify a text file on an FTP server: 
 

1. Connect to the FTP site and navigate to the folder containing the text file. 
 

2. Select the file you want to edit. 
 

3. Choose Commands > File Actions > Edit from the menu bar.  This will launch CuteHTML and load the file. 
 

4. Modify the file using CuteHTML. 
 

5. From CuteHTML’s File menu choose Save to Remote. 
 

6. CuteFTP will automatically upload the changes. 
 
Note 
CuteHTML is the default editor.  You can change the default editor under Edit > Settings > Helper Applications from the menu bar; 
however, you will lose the Save to Remote feature. 
 
Executing a file on an FTP site 
 
CuteFTP allows you to run a file from its current location, like a browser, by performing the following: 
 

1. Connect to the FTP site and navigate to the folder containing the file you want to run. 
 

2. Select the file you want to run. 
 

3. Choose Commands > File Actions > Execute from the menu bar. 
 
Creating a new folder 
 

1. Connect to the FTP site where you would like to create the new folder.  
 

2. Click the folder in which you want to create a new folder. 
 

3. Choose Commands > Directory > Create new directory from the menu bar. 
 

4. Type in the new folder name and click the OK button. 
 
Copying or moving a file or folder 
 

1. Connect to the FTP site. 
 

2. Click the file or folder you want to copy or move. 
 

3. On the Edit menu click Copy.  Or, click Cut to move the item. 
 

4. Open the folder where you want to copy or move the item. 
 

5. On the Edit menu click Paste. 



CuteFTP 5 XP User’s Guide 11

 
Note 
FTP servers do not support copying.  If you select a file, choose Copy and then choose Paste, you will move the file rather than copy it.  
If you need to copy a file on an FTP server you must first download it, then re-upload it to its new location. 
 
Changing the name of a file or folder 
 

1. Connect to the FTP site. 
 

2. Click the file or folder you want to rename. 
 

3. Choose Commands > File Actions > Rename from the menu bar. 
 

4. Type the new name, and then click the OK button. 
 
Deleting a file or folder 
 

1. Connect to the FTP site. 
 

2. Click the file or folder you want to delete.  You can also Shift + click or Control + click to select multiple items. 
 

3. Press the DELETE key on your keyboard. 
 
Changing permissions of files or folders on a UNIX FTP server 
 
If you have permission, you may use CuteFTP to change file and folder permissions on UNIX FTP servers by doing the following: 
 

1. Connect to the UNIX FTP server. 
 

2. Click the file or folder you want to change permissions. 
 

3. Select Commands > File Actions > CHMOD from the menu bar. 
 

4. Check the appropriate Read, Write and Execute check boxes. 
 

5. Click the OK button. 
 
Notes 
 

• A gray check box means that only some of the selected files have that permission. 
 

• You can also enter a three-digit numerical permission value into the Manual box.   
 

First digit: Defines the permissions for the owner. 
 
Second digit: Defines the permissions for the group. 
 
Third digit: Defines the permissions for everyone else (referred to as public). 
 
Digit Values 

Digit Selected check boxes in CuteFTP’s Change 
File Attributes box 

File or folder permission 

0 No check boxes selected --- 
1 Execute --x 
2 Write -w- 
3 Write, Execute -wx 
4 Read r-- 
5 Read, Execute r-x 
6 Read, Write rw- 
7 Read, Write, Execute rwx 
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Retrieving directory information 
 
CuteFTP collects folder Information and can display paths, number of files, combined file size, and other information for all files.  Do the 
following to view directory information.  
 

1. Connect to your FTP server. 
 

2. Use your mouse to place the focus on the local or remote pane. 
 

3. Select Commands > Directory > Directory Information from the menu bar. 
 
Comparing local and remote folders 
 
Contents of local and remote folders can be compared using the Compare Directories command.  To use Compare Directories: 
 

1. Connect to your FTP server. 
 

2. Navigate to the desired folder in both the local and remote panes 
 

3. Select Commands > Directory > Compare Directories from the menu bar.  Select the desired comparison options: 
 

• Ignore Letter Case: Will NOT look at capitalization during comparison. 
 

• Compare Sizes: Will look at file size during comparison.  
 

• Compare Dates: Will look at file dates during comparison.  
 

4. The files that match will NOT be highlighted. 
 
Saving default remote and local paths to the Site Manager 
 
You can avoid typing long paths to the default local and remote folders in the Site Manager by doing the following:  
 

1. Connect to your FTP server. 
 

2. Navigate to the local and remote folders that you want CuteFTP to go to when you first connect to the FTP server. 
 

3. To save the current local or remote directory path information to the FTP Edit Site screen, select Commands > Session > 
Save remote path to SM or Save local path to SM.  The next time you connect to the FTP server you will automatically be 
placed in the newly defined default folders. 

 
Using Bookmarks to select locations on an FTP server 
 
CuteFTP uses bookmarks to mark local and remote folders n the Site Manager.  Only bookmarks specific to an open site will be 
available for use. 
 
Adding a bookmark to a remote folder 
 

1. Connect to your FTP server. 
 

2. Navigate to the desired remote folder. 
 

3. Select Bookmarks > Add from the menu bar. 
 

4. Type a name for the bookmark and click the OK button. 
 
Adding a local folder to a bookmark 
 

1. Choose File > Site Manager from the menu bar. 
 

2. Click the site with the bookmark, then click the bookmark. 
 

3. Type the path to the local folder in the Local Path box you want CuteFTP to go to when you select the bookmark or check the 
Use default local path from site check box to use the default folder you added to the Site Manager for the site. 
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Going to bookmarked folders 
 

1. Choose File > Site Manager. 
 

2. Click the bookmark under the site it is associated with or connect to the site and choose the bookmark from the Bookmark 
menu. 

 
Editing bookmarks 
 

1. Connect to your FTP server that contains the bookmark. 
 

2. Select Bookmarks > Edit from the menu bar. 
 

3. Select a bookmark and click the Edit or Remove button. 
 
Getting links as a file or folder 
 
This command directs CuteFTP to get a directory link as a file so you do not have to change directories to get files.  From the menu 
bar, click Commands > File Actions > Get Link as File.  The contents of the linked directory will begin downloading. 
 
Printing the contents of a folder 
 
Select File > Print from the menu bar to print the contents of the folder of the currently selected pane. 
 
Using filters to control which files are displayed 
 
CuteFTP can use filters to hide files in the local and remote windows.  Filtering works by matching each filename in a folder against a 
user-defined wildcard mask.  You can create filter masks that show only specified files or create “filter NOT masks” that show all files 
except specified files. 
 
Adding or Removing a Filter 
 

1. Connect to your FTP Server 
 

2. Choose Edit > Filter from the menu bar or to have this filter apply to only one site, locate the site in the Site Manager and click 
the Edit button > General Tab > Filter button. 

 
3. Click the Filter Mask tab and add wildcards to define files that you want to appear in your folder list while all others are hidden. 

 
4. Click the Filter NOT mask tab to add wildcards to define files that you do not want to hide while allowing all others. 

 
5. Click the OK button. 

 
Filter Options 
 
The Edit > Filter > Options tab has several selections you may use to help with filtering files. 
 

• Apply filters to local directory listing: This option applies filters to the local directory listing. 
 

• Apply filters to remote directory listing:  This option applies filters to files displayed in the remote directory listing. 
 

• Apply filters to folder name(s):  This choice causes directories to be affected by the filters. 
 

• Let CuteFTP do the filtering (recommended):  CuteFTP applies the filters you have defined. 
 

• Enable remote filters (Server applied filter):  CuteFTP sends a command containing the filter to the server. You must define 
filters to be sent in the box below this option. 

 
• Apply filters to uploads/downloads: CuteFTP filters files during uploads and downloads. 

 
• Apply filters to site-to-site transfer:  Filters are enabled when transferring files using site-to-site transfers. 

 
• Case sensitive filtering:  Filters will be case sensitive, i.e. *.JPG is a different filter than *.jpg. 

 
• Displaying Hidden Files: You can display hidden files on servers using a special filter command.  When configuring your 

filter, select Enable remote filters (Server applied filter).  Type in -rtaF next to this field. Your listing command should now 
be LIST-rtaF, which will display of hidden files. 
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To select groups of files using filters 
 

1. Select Edit > Group Select from the menu bar. 
 

2. Enter a wildcard expression in the Filter Mask field. 
 

3. Select Mask Directories if you would like to filter directories as well as files. 
 

4. Select Remove Selection to clear currently selected items before selecting masked items. 
 

5. Press OK and the filter selection will be performed on the current selected pane. 
 

• To invert the selected files (highlights files not matching the filter):  From the menu bar, click Edit > Invert Selection. 
 

• To deselect a group of files:  From the menu bar, click Edit > Group Deselect. 
Notes 
 
Wildcards are patterns of special characters used to filter file names.  When a wildcard is matched against a file name, the two patterns 
are compared, letter-by-letter, from left to right until a mismatch occurs. If all the characters in both patterns compare positively, the file 
name matches the wildcard. 
 
Wildcard Mask Examples 

Mask Will Match 
* all files 
*.bmp sample.bmp, xyz.bmp, but not sample.gif 
x?z xyz, xaz, but not xyy 
a[xyz]c axc, ayc, azc, but not abc 
a[!xyz]c abc, adc, afc etc, but not axc 
a[a-c]d aad, abd, acd, but not axd 
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Automating CuteFTP 
 
Pasting an FTP address from the clipboard into CuteFTP 
 
Perform the following steps to connect to an FTP server by pasting an FTP address into CuteFTP  
 

1. Select an FTP URL in any Windows application and copy it to the clipboard using Edit > Copy. 
 

2. Return to CuteFTP and select File > Paste URL from the menu bar. 
 

3. Right-click in the Paste URL window and choose Paste. 
 

4. Click the OK button. 
 
Automatically connecting to FTP sites when an FTP address is in the Clipboard 
 
You can configure CuteFTP to automatically connect to an FTP site when an FTP address is in the Windows Clipboard.   
 

1. From the menu bar choose Edit > Settings > Advanced. 
 

2. Check the Monitor Clipboard for FTP URLs check box. 
 

3. Click the Apply button.   
 
Record a macro in CuteFTP 
 

1. To start recording a macro choose Commands > Macros > Start Recording from the menu bar.  Connect to your site and 
perform the tasks you want to record.  Every command and keystroke will be saved from this point. 

 
2. When you are finished recording the macro click Commands > Macro > Stop Recording. 

 
3. Enter a name for the macro in the Filename box and click the Save button. 

 
Note 
Commands that can be recorded are limited to transfers (including wildcards), uploads, downloads, deletions, and directory changes.  
To have the macro shut down CuteFTP after the transfer executes, edit the script file that was created and add the word SHUTDOWN 
to the last line. 
 
Executing a macro from within CuteFTP 
 

1. Select Commands > Macros > Execute Macro from the menu bar. 
 

2. Choose the macro file to execute and click OK. 
 
Executing a macro from the command line 
 
Use the following command to automatically launch CuteFTP and execute your macro:  
 
“[path to CuteFTP executable]" Macro=[path to saved macro] 
Example:  "C:\Program Files\GlobalSCAPE\CuteFTP\CutFTP32.exe" Macro=c:\Scripts\DailyUpload.mcr 
 
Note 
Quotes are required for paths containing spaces. 
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Automatically renaming transferred files 
 
CuteFTP can rename file extensions during uploads. For example, you can set CuteFTP to automatically convert .htm to .html. 
 

1. From the menu bar choose Edit > Settings >Auto Renaming. 
 

2. Click Add and enter the local file extension in the Local field. 
 

3. Enter the desired new extension in the Remote field and click the Apply button then the OK button. 
 

4. Open the Site Manager and choose Edit for each site the auto-rename scheme should apply to. 
 

5. Switch to the Advanced tab and check the Use Auto-Rename Scheme check box.  
 
Adding custom commands 
 
You can choose from pre-defined commands or create custom commands to communicate with a server.  ISPs normally distribute to all 
subscribers a custom commands file (COMMANDS.DAT) for their Web server.  Perform the following to add a custom command to 
CuteFTP. 
 

1. Select Commands > Custom Commands > Define from the menu bar. 
 

2. Type a name for your new command in the Label field. 
 

3. Enter the text for your command in the Command Text field.  The command text is the actual FTP command sent to the 
server. 

 
4. Enter an optional hot key in the Hot Key field.  The new command can be executed using Control+Shift plus this hot key. 

 
5. Click the Add button.  You can access your new command by choosing Commands > Custom Commands from the menu 

bar. 
 
Adding variables to your custom commands 
 

• %[ prompt ]: When this variable is encountered, CuteFTP displays a prompt dialog box with an input field.  You can then type 
any text in the input field, which will be inserted into the actual command text in place of the variable. "Prompt" can be any text, 
not containing [ ] (square brackets).  It will be used as a title for the prompt dialog box.  

 
• %f: This variable will be substituted by the name of the file currently selected in the remote browser.  If more than one file is 

selected, the command will be repeated for each file. 
 

• %%:  A single % character. 
 

Common command examples: 
 
SITE CHMOD %[New Access Mask] %f:  This command will prompt the user for a "New Access Mask" and use it for each 
selected file. For instance, if user enters "=rwx" at the prompt, and FILEA.TXT, FILEB.TXT and FILEC.TXT files are selected, 
the following sequence of commands will be sent to the server: 
SITE CHMOD =rwx FILEA.TXT 
SITE CHMOD =rwx FILEB.TXT 
SITE CHMOD =rwx FILEC.TXT 
 
SITE INDEX %[Search Text]: This command will prompt for "Search Text" and send a single command to the server. For 
instance, if a user enters "CuteFTP" at the prompt, the following command will be sent to the server: SITE INDEX CuteFTP. 

 
Note 
The Show Server's Response switch specifies whether CuteFTP should display the server's response to the command.  If set, a dialog 
box will pop up containing a command-response sequence for each command executed.  The Hot Key box is a keyboard accelerator 
assigned to the command.  
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Manually inputting a command to an FTP server. 
 
You can manually enter any command to an FTP server by performing the following: 
 

1. Connect to an FTP server. 
 

2. Right-click in the log window. 
 

3. Choose Input FTP command from the menu. 
 

4. Enter the command in the Input FTP command box. 
 

5. Click the OK button. 
 
Shortcut Keys 
 
Depressing the Alt key allows access to the menu bar via the keyboard.  Use the arrow keys to navigate the menus, or press the 
underlined letter to go directly to that menu. 
 

Key Function 
Delete Delete File 
Backspace  Directory Up 
Tab Switch Browser Focus 
F1 Help 
F2 Rename 
F3 Find Next 
F4 Site Manager 
Control-F4 Quick Connect 
Shift-F4 Disconnect 
F5 Refresh Screen 
F6 Toggle Local Window 
F7 Toggle Remote Window 
F8 Directory Information 
F9 Stop Transfer 
Escape Stop Transfer 
F10 Toggle Queue Window 
F11 Compare Directories 
F12 Toggle Log Window 
Control-A Select All 
Control-Shift-A Change Attributes 
Control-C               Copy 
Control-D Change Directory 
Control-E Execute File 
Control-F Find 
Control-G Short Listings 
Control-H Long Listings 
Control-I Load Index 
Control-L Filter 
Control-M Make New Directory 
Control-P Paste URL 
Control-Q Quit CuteFTP 
Control-R Reconnect 
Control-U Change User 
Control-V Paste 
Control-W View File 
Control-X Cut 
Control-PgDn  Download 
Control-PgUp  Upload 
Numberpad +  Group Select 
Numberpad -  Group Deselect 
Numberpad * Invert Selection 
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CuteFTP Settings 
 
To configure CuteFTP’s settings, select Edit > Settings from the menu bar.  The Settings window displays a list of configuration 
categories on the left-hand side, and the settings themselves on the right. 
 
Advanced settings 
 
CuteFTP’s Advanced settings can be accessed by choosing Edit > Settings > Advanced from the menu bar. 
 
 
Monitor Clipboard for FTP URLs 
Activates CuteFTP's URL parsing feature.  Any time an FTP URL is copied onto the Windows Clipboard, CuteFTP will automatically 
connect to the site and begin downloading the target file.  This feature assumes an anonymous login. Note that the monitor clipboard 
function does not currently support redirected URLs. 
 
Minimize to System Tray 
When minimized, CuteFTP places a small icon in the System Tray rather than a standard Task Bar button. 
 
Save Quick Connect History 
When enabled, CuteFTP stores recently accessed Quick Connect sites in the Quick Connect Bar's pull-down menu.  If deselected, 
CuteFTP will clear these entries upon exit. 
 
Delete to Recycle Bin 
If this box is checked, CuteFTP will send files deleted from your local system to the Recycle Bin.  If unchecked, deleted files will be 
permanently removed from your computer.  This check box has no effect on deleting remote files. 
 
Use REST before APPE when resuming 
The REST (restore) command is a more efficient but less widely supported way to resume file uploads.  If REST is rejected, CuteFTP 
uses APPE (append), the default, to resume.  
 
Treat leading zeros in IPs as octal numbers 
This setting alerts CuteFTP to treat leading zeros as a cue to octal (base eight) programming.  Decimal (base ten) programming 
dominates the field at this time, so octal programming should not affect the majority of transfers.  
 
Check file size on download 
CuteFTP will compare the file size on the file you have downloaded with the file on the server to ensure an accurate transfer.  
 
Retry last XXX bytes when resuming transfers 
If you are worried about corruption as the result of a broken transfer, specify the point (number of bytes) at which CuteFTP will resume 
downloading.  For example, a transfer might break at 420 bytes.  If you had specified 100 bytes for this option, CuteFTP would resume 
the transfer at 320 instead of 421 bytes. 
 
Receive/Send Buffer 
This shows the size in bytes of transmission buffers.  Larger values may increase performance at the cost of higher RAM usage.  
Generally, there is no need to modify these values. 
 
Enable right-click shell integration 
Allows file transfers from Windows Explorer or Desktop.  Refer to Transferring Files with CuteFTP section for more information. 
 
Prompt for directory when doing right-click transfers 
CuteFTP asks for a destination directory rather than using the default directory.  
 
Auto Renaming settings 
 
CuteFTP’s Auto Renaming settings can be accessed by choosing Edit > Settings > Auto Renaming from the menu bar. 
 
This section of the Settings dialog box configures CuteFTP's automatic renaming ability.  For more information on the configuration and 
use of auto renaming, refer to the Automatically renaming transferred files section. 
 
Connection settings 
 
CuteFTP’s Auto Renaming settings can be accessed by choosing Edit > Settings > Auto Renaming from the menu bar. 
 
E-Mail Address 
This is the email address CuteFTP will provide to FTP server that you connect to anonymously.  You may enter whatever you want 
here, but some servers will check the address for validity and refuse your connection if it's invalid. 
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Upon startup launch 
You can choose whether CuteFTP launches the Site Manager or connects to your default site during startup. 
 
Connection retries & Retry delay 
Use these settings to control the number of times CuteFTP will attempt to connect to an FTP server before it considers the FTP server 
inactive and the number of seconds between attempts. 
 
Always check and store 'resume transfer capability' for each site 
The Site Manager can remember whether or not each site supports resuming broken transfers.  This will speed up connections since 
CuteFTP won't have to check for this capability each time it connects to the site. 
 
Enable Persistent Downloading 
CuteFTP will automatically reconnect and resume in the event of an interrupted transfer. 
 
Reconnect and resume if 0 bytes in __ seconds received 
If a transfer stops for this number of seconds then CuteFTP will attempt to reconnect and resume the transfer. 
 
After a transfer is completed 
You can program CuteFTP to automatically disconnect from a site, close, disconnect your modem, log off, or shut your computer down 
after a file transfer is complete.  This is useful when you are automating transfers. 
 
ASCII/Binary settings 
 
You can define file extensions that should be transferred in ASCII mode choosing Edit > Settings > Connection > ASCII/Binary from 
the menu bar.  To add additional ASCII file extensions click the Add button and type in the extension, not including the dot.  You can 
remove file extensions that are transferred in ASCII mode by selecting them from the Text File Extensions list and clicking the 
Remove button. 
 
Default transfer type 
You can configure the default transfer mode for all transfers as ASCII, Binary or Auto-detect.  Auto-detect is recommended unless you 
are having problems with files being transferred in the wrong mode. 
 
DUN/LAN (Dial Up Networking) 
 
If you use a modem for your Internet CuteFTP can automate dialing tasks.  Choose Edit > Settings > Connection > DUN/LAN to 
configure how CuteFTP interacts with your modem. 
 
Show authentication window (requires user input) 
You will be prompted for your ISP username and password before connection occurs. 
 
Show error prompts (requires user interaction) 
Messages indicating an action to take will appear when errors occur. 
 
Disconnect from the Internet upon program exit 
Your connection to the Internet will be terminated when you exit CuteFTP. 
 
Number of times to attempt connection 
If the connection fails, CuteFTP will retry connecting to your ISP this number of times before giving up. 
 
Number of seconds to wait between attempts 
This indicates the delay between connection retries. 
 
Firewall settings 
 
A firewall or proxy server is a safeguard utilized by many networks to protect it from unauthorized access from the outside.  If you are 
using CuteFTP with a firewall or proxy server that blocks FTP transfers, you will need to perform the following steps: 
 

1. Choose Edit > Settings > Connection > Firewall from the menu bar. 
 

2. Enter your Proxy server name or IP address In the Host field. 
 

3. Enter your port number in the Port field.  Typically it is 21. 
 

4. Enter your username in the User ID field (if needed). 
 

5. Enter your password in the Password field (if needed). 
 

6. Select your firewall Type.  
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7. Check the Enable firewall access check box. 

 
Defining a Custom firewall type 
 
Custom firewall type is only necessary if the predefined firewall types do not work for you.  To use custom firewall logons, select 
Custom in Step 6 above and click the Settings button.  The following variables may be used to define a custom login script: 
 
Variable Description 

%HOST% The address of the FTP site to connect. 
  
%USER% Valid username for the FTP server. 
  
%PASS% Password associated with the specified FTP user name 
  
%PORT% Port used by the FTP server. If this command is not used, it will 

default to 21 (the standard FTP port). 
  
%FIRE_USER% Firewall username. Some network configurations may require a 

login for the firewall 
  
%FIREPASS%   Password associated with the firewall username. 
 
Custom firewall example 
 
Enter each command necessary to initiate an FTP session with the remote server, one command per line.  A typical series of 
commands might look like this: 
 
fire_user jimmy 
fire_pass $53a&8* 
host ftp.microsoft.com 
user anonymous 
pass somename@domain.com 
port 21 
 
This will first send the user name jimmy and the password $53a&8* to the firewall/proxy server (as required by that specific server 
configuration).  Then, CuteFTP will open a connection to the Microsoft FTP site and log in anonymously on port 21. 
 
Index file settings 
 
You can to specify which filenames are treated as FTP index files and how large the file can be before you are prompted by performing 
the following:  
 

1. Choose Edit > Settings > Connection > Index Files from the menu bar. 
 

2. If you want to be prompted when you encounter a large index file, then enter that size in the Maximum safe index file 
size:__Kilobytes box. 

 
3. Check the Auto-load index files to memory check box to automatically cache index files for quick access. 

 
4. Add or remove filenames from the FTP index file list using the following logic: 

 
Click Add in the index mask column to enter additional masks.  You will also notice a NOT mask column, which tells 
CuteFTP which files are not index files.  Add masks to this column in the same fashion. 
 
If you look at the default Index files mask list, you will notice a file name *index* using Wildcards.  CuteFTP will consider any 
file with the word "index" in it to be an index file.  That could cause a problem since your Web page might be called index.htm.  
However, CuteFTP passes the file name through a second filter, the Index files NOT mask, and sees the *htm extension in 
the list.  It will no longer consider your Web page an index file because of the double filtering system. 

 
 
Log file settings 
 
The log window visible in the upper portion of the CuteFTP screen shows every action performed and server response.  You can save 
the contents of the log window to a log file by performing the following: 
 

1. Choose Edit > Settings > Connection > Log on the menu bar. 
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2. Check the Save logs to files check box. 

 
3. Choose how often to rotate the log file by selecting Daily, Weekly or Monthly. 

 
4. Use the browse button to select the folder where you would like your log files saved. 

 
5. Check the Show client commands in display log check box to record commands sent by CuteFTP. 

 
6. Check the Show server commands in display log check box to record server messages. 

 
7. Click the Apply and OK buttons. 

 
Smart Keep Alive settings 
 
CuteFTP compensates for idle timeouts during sessions with Smart Keep Alive.  It sends commands at random intervals to the FTP 
server to help maintain an active connection.  Choose Edit > Settings > Connection > Smart Keep Alive to configure the following 
settings: 
 
Enable Smart Keep Alive (SKA) 
When checked, SKA will be active when connected to any FTP site. 
 
Start SKA ____ seconds after the last command 
CuteFTP will begin using SKA after the specified idle time. 
 
Maintain SKA for ____ minutes 
CuteFTP will maintain a connection to the FTP server for the specified length of time. 
 
Send command at random intervals between ____ and ____ seconds 
Commands will be sent to the server using the random interval specified. 
 
Add or remove SKA commands 
Have SKA use these commands in random order: Click Add or Remove to customize the commands listed. CuteFTP will issue a 
random command in the list when utilizing SKA. 
 
Enable auto-reconnect if booted from the server using a ___ second delay 
If the server terminates the connection, CuteFTP will automatically reconnect to the FTP site. 
 
Obtain a new IP address when reconnecting 
CuteFTP will disconnect and then reconnect to the Internet before establishing a connection to the FTP server.  This works only with 
dialup accounts. 
 
SOCKS settings 
 
If your network uses the SOCKS protocol, the following settings allow you to connect to external FTP sites.  See also the Firewall 
settings for related options.  Contact your System Administrator to obtain needed information.  Choose Edit > Settings > Connection 
> SOCKS to configure the following settings: 
 
 
Use direct connection 
Select if you do NOT use the SOCKS protocol on your network. 
 
SOCKS4 
Select if your network uses the SOCKS4 protocol. You must also enter the SOCKS Host and Port Number. 
 
SOCKS5 
Select if your network uses the SOCKS5 protocol. Enter the Host and Port Number.  If Use user/password for SOCKS5 proxy is 
checked, enter the UserID and Password supplied by your System Administrator. 
 
Host/Port 
The host name and port number of the SOCKS proxy server. 
 
User ID/Password 
The User ID and password for the SOCKS proxy server. 
 
Note 
You can disable SOCKS and Firewall support for local addresses by checking the Don’t use socks and other proxy for local 
addresses check box located under Edit > Settings > Connection > Firewall. 
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WarFTP Specific settings 
 
These settings are specific to WarFTP servers.  WarFTP treats PASV mode and links differently. CuteFTP circumvents this with the 
following options available at Edit > Settings > Connection > WarFTP Specific: 
 
Force RFC compliant PASV mode 
Uncheck if you are having problems connecting to WarFTP sites, or receive error messages indicating that PASV mode is not 
supported. 
 
Treat .lnk files as linked files 
If this is enabled, CuteFTP will treat .lnk files as links instead of directories. This solves problems with directory navigation when 
connected to WarFTP sites. 
 
Directory Navigation settings 
 
Under Edit > Settings > Directory Navigation, you can configure the following options. 
 
Default Download Directory 
Downloaded files will be placed into this directory unless you navigate to another directory in the local pane. 
 
Remember the last local directory used 
The directory visible in the local pane upon exiting CuteFTP will automatically display at the next startup. 
 
Auto-refresh remote directory 
The contents of the remote pane are refreshed each time you perform operations in that pane. 
 
Refresh after cancelled transfer 
The remote pane will be refreshed even if your transfer is cancelled. 
 
Symbolic Links 
Symbolic links are similar to "Shortcuts" in Windows: special files that act as pointers to other files or directories.  You can select how 
you want symbolic links displayed in the remote pane. Typically you will want to resolve links, meaning you will see the actual file or 
directory in the remote pane. 
 
Resolve links and display L attribute 
Links are resolved and flagged with a special L attribute.  The remote pane must be in Long Listing mode to see file attributes. 
 
Resolve symbolic links 
Symbolic links are resolved, but no special attribute is set.  
 
Do not resolve links 
The actual link files are displayed instead of the files they point to.  
 
Use logical parent directory 
When navigating directories using links, CuteFTP will return to the linking directory when pressing the Parent Directory button instead of 
the actual parent directory.  For example, suppose you are in /dir1, and double-click link zzz pointing to /dir2/subdir.  With this option 
enabled, you return to /dir1 when pressing the up arrow button.  Without it, you return to dir/2. 
 
Display settings 
 
Under Edit > Settings > Display, you can configure the following options. 
 
Show splash screen 
Here you can either enable or disable the CuteFTP splash screen at startup. 
 
Show full directory path in local pane 
The entire pathname is displayed in the local directory pane.  If disabled, only the current folder name displays. 
 
Show file sizes in bytes 
All file sizes are listed in bytes instead of kilobytes or megabytes. 
 
Auto-save sorting settings 
Remember the last used sort operation and automatically apply it to new sessions. 
 
Show cumulative file size in queue status bar 
A byte total for all queued files appears in the Queue Window status bar.  
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Auto hide quick connect after each use 
The Quick Connect bar can be made to automatically disappear after use.  If disabled, the Quick Connect bar must be manually toggled 
using the Quick Connect button on the toolbar. 
 
Don't show system icons 
Instead of the regular file icons you might see in Windows Explorer, CuteFTP will display a set of generic icons, speeding up directory 
listings. 
 
Show Text 
Select this box to display text under the buttons on the Toolbar. 
 
Customize 
Select this box to allow addition and removal of buttons on the CuteFTP main window though the Customize Toolbar screen. 
 
Double-click action 
Select Transfer, View, Execute, or Nothing as your default action.  Transfer causes files in the local pane to be uploaded, and files in 
the remote pane to be downloaded.  View displays the file in the Windows Notepad.  Execute runs applications. 
 
Color settings 
 
Under Edit > Settings > Display > Colors, you can configure pane and log text colors. 
  
To select a basic color from the palette: 
 

1. Find the pane or text field you want to modify. 
 

2. Click the colored square next to the field name. 
 

3. From the color palette, click the basic color you want to apply to the field then click OK. 
 
To create a Custom Color: 
 

1. Find the pane or text field you want to modify. 
 

2. Click the colored square next to the field name. 
 

3. Click the Define Custom Color button. 
 

4. Move to the new color palette (right side) to click and drag the 4-point black cursor (usually at the top or bottom) through the 
color grid. 

 
5. When the Color/Solid block displays the desired color, click the Add to Custom Colors button. 

 
6. Move back to the first palette. Under the Custom Colors area located at the bottom of the box, click the new color and click 

OK. 
 
Font settings 
 
In Edit > Settings > Display > Fonts, fonts for CuteFTP and the Log window can be changed. 
 
To change CuteFTP’s fonts: 
Click the Select Font button in the Program Font box.  Select the desired font and size from the resulting menu. 
 
To change the log window fonts: 
Click the Select Font button in the Log Window Font box.  Select the desired font and size from the resulting menu. 
 
Sound settings 
 
Connect and end transfer sounds are audio tones played when connection to the server occurs and when transfers are complete.   
 
In Edit > Settings > Display > Sound, you may select standard Windows sounds or use a sound file from another source.  Select from 
the list the event you want to change.  To select a default sound, choose it from the File drop-down menu.  To choose a custom sound, 
click the Browse button next to the File drop-down menu, and locate a sound file.  Click the Speaker button to preview a selected 
sound. 
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Helper Applications 
 
Two helper applications may be selected: a text viewer and an HTML editor.  When you use the View or Edit functions in CuteFTP’s 
right-click menu when connected to an FTP server, these helper applications are "fed" the selected files. To select helper applications, 
in Edit > Settings > Helper Applications, click the Browse button next to each field and browse to the desired executable.  Notepad 
is selected as the default text viewer. CuteHTML is selected as the default HTML editor. 
 
Note 
You must have CuteHTML selected as your HTML editor if you want to take advantage of Save to Remote.  This allows you to modify 
and save an HTML file on the FTP server without having to manually download, open, modify, save and upload the file. 
 
Message prompt settings 
 
CuteFTP sends various informational prompts during a session.  You can specify which prompts are displayed under Edit > Settings > 
Prompts from the menu bar.  Deselect the check box next to the prompt you want to turn off.  
 

• Overwrite Confirmation (Download/Upload): Select this box to direct CuteFTP to prompt you if your transfer operation is 
about to overwrite a file. 

 
• Automatically close prompt windows after ___ seconds: Select a default number of seconds to display a prompt window 

before automatically closing.  
 

• Transfer Binary File in ASCII Mode Warning: Select this box to direct CuteFTP to warn you if you are about to transfer a 
binary file (.exe, .wav, etc.) in ASCII mode. 

 
• Delete Confirmation/Delete from queue confirmation: Select these boxes to direct CuteFTP to prompt you when deleting a 

file or queue item. 
 

• Drag-Drop Operations Confirmation: Select this box to direct CuteFTP to prompt you for confirmation when you drag and 
drop files. 

 
• Disconnect During Transfer Confirmation:  Select this box to direct CuteFTP to issue a warning message when you try to 

disconnect during a transfer. 
 

• Missing Permissions: Select this box to direct CuteFTP to issue a prompt when your server does not allow the operation you 
are attempting to perform. 

 
• Can't Connect to Server: Select this box to direct CuteFTP to issue a prompt with help functions available for connection 

problems. 
 

• "File unavailable" (ratio sites): Select to enable warnings when upload/download ratios are violated. 
 

• Prompt for user and pass when login fails: CuteFTP will prompt for a user and password if your login sequence fails. This 
can be turned off if you are sure you have entered the correct user and pass and are being rejected by the server due to other 
reasons, such as when there are too many users attempting to connect to the server. 

 
• Login message: Displays the login messages sent by the FTP server. 

 
• Directory messages: Show server messages when changing directories. 

 
• Confirm file names: Prompts when changing file names. 

 
• Missing permissions: Warning displayed if CHMOD is done incorrectly. 
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Searching for Files 
 
Using CuteFTP to query FTP search engines 
 
CuteFTP has the ability to query Internet FTP search engines and provide results in the CuteFTP interface.  Perform the following steps 
to search FTP sites using CuteFTP’s File Finder: 
 

1. Choose File > File Finder from the menu bar. 
 

2. Enter the filename you are looking for in the Filename box 
 

3. Select the search engines you want to query by checking the appropriate Search Engine check boxes. 
 

4. Click the Search button. 
 

5. Select the file you want to download from the results list and click Add to Queue button.  If you are looking for a “difficult to 
acquire file” then try the Smart Get button.  It will add all occurrences of the filename you have selected from the results list to 
the queue.  It will then attempt to download each occurrence until success. 

 
Note 
You can right-click and select Find in the search results to perform more flexible searches and downloads.  A dialog box appears that 
allows you to perform more specific or more general searches on the search results. Type the search term (no wildcards) in the Find 
what field.  Use the filters on the left to further narrow your search.  Use the Find Next button to scroll through every found file or click 
the Mark All button to select all of them. 
 
Using the File Finder with ratio sites 
 
Many FTP sites are run as "ratio sites".  Operating under a type of file trading system, these sites do not allow downloads until you have 
uploaded a file or files.  Credits are issued for the uploaded files and these credits, in turn, enable downloading from the site.  The error 
message "Insufficient credit for download - upload first" is issued from a ratio site.  Refer to the index or text file on that site for 
instructions on uploading to their server. 
 
If searching for MP3s using the Smart Get feature, you may have trouble with ratio sites.  If Smart Get receives a ratio site error, it will 
move on to the next server without giving you a chance to upload.  However, if you really want a file on a ratio site, then perform the 
following steps to download the file you added to the queue using Smart Get: 
 

1. Select the file from the queue and press the Stop button (or F9). 
 

2. Right-click the file in the queue and choose Reset Status. 
 

3. Now, you need to upload a file to this ratio site.  Look for an upload directory on the site.  Go to the root directory by pressing 
the yellow Up Directory button. Once you locate the upload folder you will need upload a file to receive the credits required to 
download a file. 

 
4. From the menu bar choose Transfer > Transfer Queue. 

 
Searching for files on an FTP server 
 

CuteFTP allows you to search the active folder for files by performing the following steps: 
 

1. Select the local or remote folder you want to find files in. 
 

2. On the menu bar choose Edit > Find. 
 

3. Enter the filename you are looking for.  You cannot use wildcards, however, searching for exe will find all files named *.exe. 
 

4. Choose F3 on your keyboard to find the next occurrence. 
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FTP Error Codes 
 
 
Code    Description    
100 Series Codes    The requested action is being initiated, expect another reply before proceeding with a new 

command.    
  
110 Restart marker reply. 
120 Service ready in nnn minutes. 
125 Data connection already open, transfer starting. 
150 File status okay, about to open data connection. 
200 Series Codes    The requested action has been successfully completed.    
200 Command okay. 
202 Command not implemented, superfluous at this site. 
211 System status, or system help reply. 
212 Directory status. 
213 File status. 
214 Help message. 
215 NAME system type. (Where NAME is an official system name from the list in the Assigned 

Numbers document.) 
220 Service ready for new user. 
221 Service closing control connection. Logged out if appropriate. 
225 Data connection open; no transfer in progress. 
226 Closing data connection. Requested file action successful (for example, file transfer or file abort). 
227 Entering Passive Mode 
230 User logged in, proceed. 
250 Requested file action okay, completed. 
257 "PATHNAME" created. 
300 Series Codes    The command has been accepted, but the requested action is being held in abeyance, 

pending receipt of further information.    
331 User name okay, need password. 
332 Need account for login. 
350 Requested file action pending further information. 
400 Series Codes    The command was not accepted and the requested action did not take place, but the error 

condition is temporary and the action may be requested again.    
421 Service not available, closing control connection. This may be a reply to any command if the 

service knows it must shut down. 
425 Can't open data connection. 
426 Connection closed; transfer aborted. 
450 Requested file action not taken. File unavailable (e.g., file busy). 
451 Requested action aborted: local error in processing. 
452 Requested action not taken. Insufficient storage space in system. 
500 Series Codes    The command was not accepted and the requested action did not take place.    
500 Syntax error, command unrecognized. This may include errors such as command line too long. 
501 Syntax error in parameters or arguments. 
502 Command not implemented. 
503 Bad sequence of commands. 
504 Command not implemented for that parameter. 
530 Not logged in. 
532 Need account for storing files. 
550 Requested action not taken. File unavailable (e.g., file not found, no access). 
552 Requested file action aborted. Exceeded storage allocation (for current directory or dataset). 
553 Requested action not taken. File name not allowed. 
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